Jump to content

CentOS or Debian?

Samurai Legend

Recommended Posts

1 hour ago, Magictallguy said:

Currently running AlmaLinux here for multiple purposes including the usual webserver setup. Beautiful OS, familiar CLI, no complaints!

Yeah im liking it so far, im migrating some of our old centos 6*/7 servers over.

* Internal IT tools with nothing important on. I.e. ticketing system/internal intranet forum etc ... 

Link to comment
Share on other sites

setting up SSH should be pretty easy by running

systemctl enable sshd --now

that should enable the SSD service and start it for you

As for the the basics of setting up a web server the two most common setups are LAMP and LEMP LAMP is more popular but LEMP is more configurable and is useful for things like port forwarding/proxies

I would read up on them both and choose acordanly, there are loads of tutorials online for both. 

As for setting up SSL you can just user certbot, again just google a hot to guide and they will explain how to do it if its LAMP or LEMP

Link to comment
Share on other sites

@DayoTerminal on MacOS (Latest)

@Dayo- After awhile, I finally got the SSH keys working, added a new user with sudo privileges, root login disabled, password disabled, using a different port. NGINX, PHP, MariaDB added. Connected my site and added SSL. 

Now I have a problem, when I go on a php page it just downloads and it doesn't read it? Any reason why? Could it be cause I don't have sites-available & sites-enabled folder? Within the nginx folder there's a folder called conf.d with the conf file of my site. 

Okay now, I have the php page working but the directory on /etc/nginx/conf.d/website.conf -> Doesn't display the correct directory? It directs to the default directory although I change it

Link to comment
Share on other sites

I am using AlmaLinux, LEMP. 

I have installed WordPress, and when I change the permalinks to post-name from ID. When, I try updating the page it throws an error:

Updating failed. The response is not a valid JSON response.

I've been searching for a fix but there's nothing working for me. Have anyone have an idea of what might the problem be?

Link to comment
Share on other sites

have you included the wordpress nginx configuration file

This should look something like this:

server {
    . . .
    location / {
        #try_files $uri $uri/ =404;
        try_files $uri $uri/ /index.php$is_args$args;
    . . .

source: https://www.digitalocean.com/community/tutorials/how-to-install-wordpress-with-lemp-on-ubuntu-20-04

Link to comment
Share on other sites

Yeah as @Magictallguy said you want to run sudo service crond status

you also want to have the cron be something like

* * * * * php /var/www/samuraiconflict/public_html/crons/minute.php?code=fdjk

edit: In fact I'm not sure you can send parameters to the file using teh GET method as its not run via a server, you will have to send the password as an argument but the best way would be to move the cron out from public_html i.e. /var/www/samuraiconflict/crons/minute.php and then you can get rid of the auth check as it can only be accessed by your server

Edited by Dayo
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...