Jump to content
MakeWebGames

Magic Quotes Help


jds137
 Share

Recommended Posts

I get the following error message, trying to reload my website. I am using Godaddy Linux Virtual Server, and their IT support is worthless.

I tried this in the .htaccess file, but got a blank page: php_value magic_quotes_gpc 1

Any help would be greatly appreciated.

 

Fatal error: MCCode cannot function without MagicQuotes GPC being turned on in PHP.INI.
Link to comment
Share on other sites

Re: Magic Quotes Help

lol Zeon that was about as pointless as a forum post can get. What makes you think this person can edit their php ini when they're going the .htaccess route?

--------------------

Anyways, on to the serious help.

You say you're on a virtual server which means the installation of php is running just for you and does not run scripts for other people on a shared server.

Do you have WHM?

If yes, then go into WHM, type "php" into the Find box on the top left.

Select "PHP Configuration Editor"

Select "Switch to Advanced Mode. "

Find magic quotes on the list, and set the setting to whatever you want. And WHM will automatically restart apache for you.

 

If you don't have WHM, then your web host (in this case Go Daddy) can edit your php ini file for you.

Link to comment
Share on other sites

Re: Magic Quotes Help

Actually I did turn it on using ssh, then this:

su - root.

vi /etc/php.ini

# Go to the line and press the "i" key.

# Change the line press the "Esc" key.

# Type :wq! to save your file.

I got a blank page, after the server reboot. I was not sure if I was doing it right, as godaddy, wants you to pay for everything. Secondly, the .htaccess file does work in some cases, as I experimented with it, and got the same result. All courtesy of google.

I really need other ideas if I am doing it right or not.

Link to comment
Share on other sites

Guest Anonymous

Re: Magic Quotes Help

Well, there's most probably loads of results on the google, but the op rather post here then use a search engine. You've literally wasted your time when he/she could of simply searched google? Also isn't it more secure for the op to have it turned off in the first place?

Link to comment
Share on other sites

Re: Magic Quotes Help

I gave you the whm idea.

But you haven't answered the question of whether or not you have WHM.

If you have that, you should follow the guidelines I layout.

---------

To Zeon: That was a pointless post. It's off topic, and doesn't help. What are you some sort of heckler or something?

Link to comment
Share on other sites

Re: Magic Quotes Help

You are using SSH, it's good enough to change the configuration of PHP.

It seems to me like you don't have the right file at hand, try locating all the PHP configuration files with the following command.

find /etc/ -name php.ini

It will list the PHP configuration files, and then use your text editor of choice to edit the file and change the value.

If you don't find the correct file after that, maybe take a look at your PHP configuration, and look for the path of the configuration file.

To do this, create a file with the following contents, within the document root that apache uses(web dir).

<?php
phpinfo();
?>

Navigate to the page within your browser(to the file name you saved the script as), and look for the value "Loaded Configuration File", it displays the path of your php configuration file.

Then using SSH, open the file in a text editor of your choice, and look fir the following line:

; Magic quotes for incoming GET/POST/Cookie data.
magic_quotes_gpc = Off

And change it to;

; Magic quotes for incoming GET/POST/Cookie data.
magic_quotes_gpc = On

Restart apache, and it should work now.

If all else fails, read this: http://www.gsdesign.ro/blog/how-to-chan ... d-servers/

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...