Jump to content
Sign in to follow this  
Sim

Form Element empty Everytime

Recommended Posts

Maybe y'all can see something I am looking past.

HTML: it's inside the form tags.

  <div class="form-group">
  <label class="pull-left">Main Type:</label>
     <select class="form-control" name="parentID" id="parentID">
   {#each itemTypes}
      <option value="{id}" {selected}>{name}</option>
    {/each}
     </select>                  
  </div>

PHP:

$data = (array) $this->methodData;
     var_dump($data);

 

DATA: as you can see all other form Elements have values that are suppose to. Name and desc

array(9) { ["page"]=> string(5) "admin" ["module"]=> string(9) "itemTypes" ["action"]=> string(3) "new" ["id"]=> string(0) "" ["name"]=> string(9) "Name test" ["desc"]=> string(16) "Description test" ["note"]=> string(0) "" ["parentID"]=> string(0) "" ["submit"]=> string(1) "1" }

 

EDIT: NVM. I forgot there's no ID, only name. {name} is supposed to be in the ID to.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...